Sunday, January 09, 2011

CCNA 640-802 Study Note Enhanced Interior Gateway Routing Protocol (EIGRP)

Besides OSPF, EIGRP is another routing protocol that supports classless routing.  EIGRP is an advanced vector routing protocol developed by Cisco.  OSPF is a link-state routing protocol.

We have a similar network setup as the OSPF lab but this time we are going to implement EIGRP instead of OSPF.

image

We will run the following commands on RouterA, RouterB and the CoreRouter.

On CoreRouter
CoreRouter(config)#router eigrp 100
CoreRouter(config-router)#network 10.0.0.0
CoreRouter(config-router)#network 172.16.31.0

On RouterB
RouterB(config)#router eigrp 100
RouterB(config-router)#network 10.0.0.0
RouterB(config-router)#network 192.168.1.0

On RouterA
RouterA(config)#router eigrp 100
RouterA(config-router)#network 10.0.0.0
RouterA(config-router)#network 192.168.1.0

The router eigrp 100 command creates an EIGRP routing process with an Autonomous System (AS) number of 100.  The AS number must be the same on all routers exchanging routing information with each other.

The network command defines the major network number to which the router is directly connected.

Wanted to test out the EIRGP authentication but unfortunately the Cisco Packet Tracer simulator does not have the commands for configuring this.  I only managed to run the command on a physical router (2600 series).  Below is the command I used on the physical router.

RouterA(config)#key chain RouterAChain
RouterA(config-keychain)#key 1
RouterA(config-keychain-key)#key-string apple
RouterA(config-keychain-key)#int s0/0/0
RouterA(config-if)#ip authentication mode eigrp 100 md5
RouterA(config-if)#ip authentication key-chain eigrp 100 RouterAChain
RouterA(config-if)#int s0/0/1
RouterA(config-if)#ip authentication mode eigrp 100 md5
RouterA(config-if)#ip authentication key-chain eigrp 100 RouterAChain

Basically, we need to do the following to enable md5 authentication for the EIGRP routing exchange.

  1. Create a key chain on each of the router taking part in the EIGRP routing exchange.  For example, key chain RouterAChain.
  2. Create key(s) for the key chain.  For example, key 1.
  3. Assign a password to the key.  For example, key-string apple where apple is the password.
  4. C0nfigure the interfaces to use authentication. ip authentication mode eigrp 100 md5 enable md5 authentication and ip authentication key-chain eigrp 100 RouterAChain specifies that the RouterAChain key chain to be used.

We can use the following command to check on the key chain configuration.

RouterA#sh key chain
Key-chain RouterAChain:
    key 1 -- text "apple"
        accept lifetime (always valid) - (always valid) [valid now]
        send lifetime (always valid) - (always valid) [valid now]

We use the following show commands to verify our EIGRP routing.

  • sh ip route – show the routing table and verify routes learned by EIGRP.
  • sh ip protocols – verify that EIGRP is enabled and the EIGRP recognizes the autonomous system (our AS number is 100).
  • sh ip eigrp neighbors – check the neighbors’ status.

Here are the output of the 3 show commands on RouterA.

Those in red are routes learned by EIGRP.

RouterA#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D       10.0.0.0/8 is a summary, 00:09:35, Null0
D       10.1.1.0/24 [90/2172416] via 10.140.1.1, 00:09:25, Serial0/0/0
C       10.2.2.0/24 is directly connected, FastEthernet0/0
D       10.3.3.0/24 [90/2172416] via 10.23.23.2, 00:09:29, Serial0/0/1
C       10.23.23.0/24 is directly connected, Serial0/0/1
C       10.140.1.0/24 is directly connected, Serial0/0/0
D       10.140.2.0/24 [90/2681856] via 10.23.23.2, 00:09:27, Serial0/0/1
                      [90/2681856] via 10.140.1.1, 00:09:25, Serial0/0/0
D    172.16.0.0/16 [90/2297856] via 10.140.1.1, 00:09:25, Serial0/0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
D       192.168.1.0/24 is a summary, 00:09:35, Null0
C       192.168.1.64/28 is directly connected, Loopback0

Our AS number is 100.

RouterA#sh ip protocols

Routing Protocol is "eigrp  100 "
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates 
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
Redistributing: eigrp 100
  Automatic network summarization is in effect 
  Automatic address summarization:
    192.168.1.0/24 for FastEthernet0/0, Serial0/0/1, Serial0/0/0
      Summarizing with metric 128256
    10.0.0.0/8 for Loopback0
      Summarizing with metric 28160
  Maximum path: 4
  Routing for Networks: 
     10.0.0.0
     192.168.1.0
  Routing Information Sources: 
    Gateway         Distance      Last Update
    10.23.23.2      90            5960      
    10.140.1.1      90            9360      
  Distance: internal 90 external 170

We can see the status of the neighbors connected to s0/0/0 and s0/0/1.

RouterA#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   10.23.23.2      Se0/0/1        11   00:25:01  40     1000  0   11
1   10.140.1.1      Se0/0/0        10   00:24:57  40     1000  0   12

Do a ping test to the TFTP server and it should work.

RouterA#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 47/59/63 ms

Okay, we have now EIGRP running on our network.

No comments: